F/R (PQ & MQC mix)

Q. What the heck is F/R EEK?
A. frame-relay end-to-end keepalive

F/R PQ & MQC mix:

Here is the only config I know to accomplish this piece of twisted mocklab torture.

Environment:

Router Y has a F/R connection to router A (no sub-interfaces allowed).

Task on page Z:

Configure the following on Serial X on router Y
frame size 64 – 127 = 28%
frame size 128 – 255 = 10%
frame size 256 – 511 = 18%
frame size 512 – 767 = 9%
frame size 768 – 1024 = 6%
the rest WFQ

Task on page Z+10:

Configure router Y so that precedence internet traffic ends up in a high priority queue on link to router A (happens to be Serial X…)

Solution:

class-map match-all 64-127
_match packet length min 64 max 127
class-map match-all 128-255
_match packet length min 128 max 255
class-map match-all 256-511
_match packet length min 256 max 511
class-map match-all 512-767
_match packet length min 512 max 767
class-map match-all 768-1024
_match packet length min 768 max 1024
!
policy-map frame-length
_class 64-127
__bandwidth percent 28
_class 128-255
__bandwidth percent 10
_class 256-511
__bandwidth percent 18
_class 512-767
__bandwidth percent 9
_class 768-1024
__bandwidth percent 6
_class class-default
__fair-queue
!
interface Serial0/0
_description *** to R_A S0 ***
_ip address 1.1.0.6 255.255.255.252
_encapsulation frame-relay
_priority-group 1
_frame-relay interface-dlci 123
_class CLASS-frame-length
_frame-relay lmi-type cisco
!
access-list 111 remark *** Match IP prec 6 (internetwork) ***
access-list 111 permit ip any any precedence internet
!
priority-list 1 protocol ip high list 111

No Responses to “F/R (PQ & MQC mix)”

Care to comment?