Other posts related to is_archive

Automating FreeIPA certificates on Palo Alto devices

 | 1 May 2023 10:12

pan_getcert is a script that uses ipa-getcert to request a certificate from FreeIPA CA and then uploads it via Palo Alto XML API to a Palo Alto firewall or Panorama, optionally updating one or two SSL/TLS Profiles with the new certificate and commits to activate the changes.

It’s hosted on GitHub: https://github.com/dmgeurts/getcert_paloalto


Introduction

Palo Alto SSL/TLS Profiles

Some uses of FreeIPA certificates on a Palo Alto firewall or Panorama:

  • Global Protect Gateway
  • Global Protect Portal
  • Management UI

Should one use an internal certificate for an external service?

There’s no need to get a publicly signed certificate as long as all Global Protect clients trust the FreeIPA (root) CA. A nice bonus is not having to permit inbound HTTP-01 traffic, which in Let’s Encrypt’s case is cloud-hosted (what else is hosted there?). Or exposing internal domains, see: Terence Eden’s Blog – Should you use Let’s Encrypt for internal hostnames?

FreeIPA CA

FreeIPA with Dogtag PKI supports certificate requests and renewals from Certmonger via ipa-getcert and since FreeIPA v4.9 also via ACME.

ACME vs Certmonger

Palo Alto firewalls nor Panorama natively support ACME, nor would I expect them to. For my lab environment, ipa-getcert is a natural choice as the server in use for certificate management is FreeIPA enrolled already, hence I have no need for anonymous ACME.

Prerequisites

pan_getcert uses ipa-getcert, the requirements are identical as far as FreeIPA is concerned:

  • An enrolled FreeIPA client with reachability to the Palo Alto firewall or Panorama.
    • Test with: nc -zv fw-mgmt.domain.local 443
    • pan-python installed
  • A manually added host (with the Service hostname).
    • The manual host must be ‘managed by’ the host on which pan_getcert will be executed.
  • A Service Principal for the service domain
    • The Service Principal must be ‘managed by’ the host on which pan_getcert will be executed.
  • An API key for the Palo Alto firewall or Panorama
    • Ideally, use a system account to tie the API key to, users tend to churn and break their API keys.
    • Store the API key in /etc/ipa/.panrc
  • IPA CA root certificate manually installed on the Palo Alto firewall or Panorama, as a trusted CA.

To install pan-python on Ubuntu 22.04:

sudo apt install python3-pip
sudo pip install pan-python

To generate the API key; first, create a user account for/on the Palo Alto and then run this from the Linux host:

panxapi.py -h PAN_MGMT_IP_OR_FQDN -l USERNAME:'PASSWORD' -k

Copy the key and paste it into /etc/ipa/.panrc as follows:

api_key=C2M1P2h1tDEz8zF3SwhF2dWC1gzzhnE1qU39EmHtGZM=

And secure the file:

sudo chmod 600 /etc/ipa/.panrc

To install getcert_paloalto:

wget https://github.com/dmgeurts/getcert_paloalto/edit/master/pan_{get,inst}cert
chmod +x pan_{get,inst}cert
sudo cp pan_{get,inst}cert /usr/local/bin/
rm pan_{get,inst}cert

Automating the two

Now that the scope is clear, it’s time to explain how getcert_paloalto automates certificate requests, deployment and renewals.

Certmonger supports has pre- and post-save commands, these can be used to run things like systemctl restart apache but also more complex commands like the name of a script with its various options. It’s this post-save option that automates the renewal process but also makes certificate deployment interesting as the same command is executed when the certificate is first created (the first save).

This is the reason there are two scripts for the solution. Also note that, as opposed to ACME, for example, no crontab entry is needed for the renewal of FreeIPA certificates. Cernmonger takes care of monitoring certificates and renewing them before they expire.

pan_getcert – Introduction

pan_getcert uses ipa-getcert (part of freeipa-client) to request a certificate from IPA CA and then sets the post-save command to pan_instcert with options based on the parameters parsed to pan_getcert. The nodes involved and the processes used are as follows:

Process overview: FreeIPA <-- Linux --> Palo Alto.

*) My OS of choice is Ubuntu hence the Ubuntu logo for the FreeIPA client machine.

pan_getcert – Options

The bare minimum options to parse are the certificate Subject (aka Common Name) [-c] and the Palo Alto device hostname.

Note: pan_getcert must be run as root, ideally using sudo. This enables admins to give certificate managers the delegated privilege to run pan_getcert as root rather than all the commands in it that require elevated privileges.

Optional arguments:

  • -n Certificate name in the Palo Alto configuration, if none is given the Certificate Subject will be used.
  • -Y Certificate name postfix of a four-digit year, prevents the existing certificate from being replaced. <certificate.name_2023>
  • -p Name of the ‘primary’ SSL/TLS Profile, will see the currently configured certificate replaced with the new certificate. if none is given, no SSL/TLS Profile will be updated.
  • -s Name of the ‘secondary’ SSL/TLS Profile, will see the currently configured certificate replaced with the new certificate. Requires [-p] to be set.

The secondary Profile option is useful in cases where the same certificate must be updated on two different SSL/TLS Profiles. It is not possible to request more than one certificate using pan_getcert from FreeIPA.

Usage: pan_getcert [-hv] -c CERT_CN [-n CERT_NAME] [-Y] [OPTIONS] FQDN
This script requests a certificate from FreeIPA using ipa-getcert and calls a partner
script to deploy the certificate to a Palo Alto firewall or Panorama.

    FQDN              Fully qualified name of the Palo Alto firewall or Panorama
                      interface. Must be reachable from this host on port TCP/443.
    -c CERT_CN        REQUIRED. Common Name (Subject) of the certificate (must be a
                      FQDN). Will also present in the certificate as a SAN.

OPTIONS:
    -n CERT_NAME      Name of the certificate in PanOS configuration. Defaults to the
                      certificate Common Name.
    -Y                Parsed to pan_instcert to append the current year '_YYYY' to
                      the certificate name.

    -p PROFILE_NAME   Apply the certificate to a (primary) SSL/TLS Service Profile.
    -s PROFILE_NAME   Apply the certificate to a (secondary) SSL/TLS Service Profile.

    -h                Display this help and exit.
    -v                Verbose mode.

pan_getcert – Actions

  1. Uses the privileges set in FreeIPA (managed by) to call ipa-getcert and request a certificate from FreeIPA.
  2. ipa-getcert will automatically renew a certificate when it’s due, as long as the FQDN DNS record resolves, and the host and Service Principal still exist in FreeIPA.
  3. Sets the post-save command to pan_instcert with the same parameters as issued to pan_getcert, for automated installation of renewed certificates.
    • Post-save will run on the first certificate save, using pan_instcert for certificate installation.

pan_instcert – Introduction

Uses panxapi.py from pan-python and can be used on its own. For example, if the certificate is created without pan_getcert. Or one might choose to use it as the post-save command of a certificate already monitored by Certmonger.

Note: pan_instcert must be run as root, ideally using sudo. This enables admins to give certificate managers the delegated privilege to run pan_instcert as root rather than all the commands in it that require elevated privileges.

pan_getcert – Options

pan_instcert options and arguments are deliberately identical to pan_getcert.

Usage: pan_instcert [-hv] -c CERT_CN [-n CERT_NAME] [OPTIONS] FQDN
This script uploads a certificate issued by ipa-getcert to a Palo Alto firewall
or Panorama and optionally adds it to up to two SSL/TLS Profiles.

    FQDN              Fully qualified name of the Palo Alto firewall or Panorama
                      interface. Must be reachable from this host on port TCP/443.
    -c CERT_CN        REQUIRED. Common Name (Subject) of the certificate, to find
                      the certificate and key files.

OPTIONS:
    -n CERT_NAME      Name of the certificate in PanOS configuration. Defaults to the
                      certificate Common Name.
    -Y                Append the current year '_YYYY' to the certificate name.

    -p PROFILE_NAME   Apply the certificate to a (primary) SSL/TLS Service Profile.
    -s PROFILE_NAME   Apply the certificate to a (secondary) SSL/TLS Service Profile.

    -h                Display this help and exit.
    -v                Verbose mode.

pan_instcert – Actions

  1. Randomly generates a certificate passphrase using “openssl rand”.
  2. Creates a temporary, password-protected PKCS12 cert file /tmp/getcert_pkcs12.pfx from the individual private and public keys issued by ipa-getcert.
  3. Uploads the temporary PKCS12 file to the firewall using the randomly-generated passphrase.
    • (Optionally) adds a year (in 4-digit notation) to the certificate name.
  4. Deletes the temporary PKCS12 certificate from the Linux host.
  5. (Optionally) applies the certificate to up to two SSL/TLS Profiles.
    • Single SSL/TLS Profile: For example for the Management UI SSL/TLS profile.
    • Two SSL/TLS Profiles: For example for GlobalProtect Portal and GlobalProtect Gateway SSL/TLS Profiles.
  6. Commits the candidate configuration (synchronously) and reports the commit result.
  7. Logs all output to `/var/log/pan_instcert.log`.

Command execution

The expected output when requesting a certificate with pan_getcert is:

$ sudo pan_getcert -v -c gp.domain.com -Y -p GP_PORTAL_PROFILE -s GP_EXT_GW_PROFILE fw01.domain.local
Certificate Common Name: gp.domain.com
  verbose=1
  CERT_CN: gp.domain.com
  CERT_NAME: gp.domain.com_2023
  PAN_FQDN: fw01.domain.local
Primary SSL/TLS Profile name: GP_PORTAL_PROFILE
Secondary SSL/TLS Profile name: GP_EXT_GW_PROFILE
New signing request "20230427151532" added.
Certificate requested for: gp.domain.com
  Certificate issue took 6 seconds, waiting for the post-save process to finish.
  Certificate install and commit by the post-save process on: fw01.domain.local took 84 seconds.
FINISHED: Check the Palo Alto firewall or Panorama to check the commit succeeded.

And pan_instcert will log to /var/log/pan_instcert.log.

[2023-04-27 15:15:33+00:00]: START of pan_instcert.
[2023-04-27 15:15:33+00:00]: Certificate Common Name: gp.domain.com
[2023-04-27 15:15:34+00:00]: XML API output for crt: <response status="success"><result>Successfully imported gp.domain.com_2023 into candidate configuration</result></response>
[2023-04-27 15:15:35+00:00]: XML API output for key: <response status="success"><result>Successfully imported gp.domain.com_2023 into candidate configuration</result></response>
[2023-04-27 15:15:35+00:00]: Finished uploading certificate: gp.domain.com_2023
[2023-04-27 15:15:37+00:00]: Starting commit, please be patient.
[2023-04-27 15:17:01+00:00]: commit: success: "Configuration committed successfully"
[2023-04-27 15:17:01+00:00]: The commit took 84 seconds to complete.
[2023-04-27 15:17:01+00:00]: END - Finished certificate installation to: fw01.domain.local

Both pan_getcert and pan_instcert will report back how long it took to do certain tasks:

  • pan_getcert
    • Time spent waiting for the certificate to be issued.
    • Time spent waiting for pan_instcert to complete.
  • pan_instcert
    • Time spent waiting for the commit to finish.

Logrotate for pan_instcert.log

This log file shouldn’t grow quickly unless there’s a problem or the number of monitored certificates grows very large. By default, IPA certificates have a two-year validity, thus monthly log lines will average at about 0.375 per certificate (9 lines / 24 months). Generally speaking, you should not expect this file to grow by more than a few lines a year.

The bigger risk is misconfiguration or changes of ipa-getcert and the Palo Alto API. And from experience, I can confirm that getcert is very persistent in retrying failed post-save commands. A few times while testing my code the log file grew to >20GB within minutes, containing only repeated pan_instcert usage instructions.

Count yourself warned! A suggestion for a logrotate.d file is:

# /etc/logrotate.d/pan_instcert
/var/log/pan_instcert.log { 
	missingok
	rotate 5
	yearly
	size 50M
	notifempty
	create
}

Verify Certificate Status and Post-save Command

Use ipa-getcert to check that the certificate ended up in status MONITORING and that the post-save command is set according to the parameters and values parsed to pan_getcert:

$ sudo ipa-getcert list
Number of certificates and requests being tracked: 2.
Request ID '20230427151532':
        status: MONITORING
        stuck: no
        key pair storage: type=FILE,location='/etc/ssl/private/gp.domain.com.key'
        certificate: type=FILE,location='/etc/ssl/certs/gp.domain.com.crt'
        CA: IPA
        issuer: CN=Certificate Authority,O=IPA.LOCAL
        subject: CN=gp.domain.com,O=IPA.LOCAL
        issued: 2023-04-27 16:15:33 BST
        expires: 2025-04-27 16:15:33 BST
        dns: gp.domain.com
        principal name: HTTP/gp.domain.com@MM.EU
        key usage: digitalSignature,nonRepudiation,keyEncipherment,dataEncipherment
        eku: id-kp-serverAuth,id-kp-clientAuth
        pre-save command:
        post-save command: /usr/local/bin/pan_instcert -c gp.domain.com -n gp.domain.com -Y -p GP_PORTAL_PROFILE -s GP_EXT_GW_PROFILE fw01.domain.local
        track: yes
        auto-renew: yes
Request ID '20230428001508':
        status: MONITORING
        stuck: no
        key pair storage: type=FILE,location='/etc/ssl/private/fw01.domain.local.key'
        certificate: type=FILE,location='/etc/ssl/certs/fw01.domain.local.crt'
        CA: IPA
        issuer: CN=Certificate Authority,O=IPA.LOCAL
        subject: CN=fw01.domain.local,O=IPA.LOCAL
        issued: 2023-04-27 16:15:33 BST
        expires: 2025-04-27 16:15:33 BST
        dns: fw01.domain.local
        principal name: HTTP/fw01.domain.local@IPA.LOCAL
        key usage: digitalSignature,nonRepudiation,keyEncipherment,dataEncipherment
        eku: id-kp-serverAuth,id-kp-clientAuth
        pre-save command:
        post-save command: /usr/local/bin/pan_instcert -c fw01.domain.local -n fw01.domain.local -Y -p MGMT_UI_PROFILE fw01.domain.local
        track: yes
        auto-renew: yes

Note the status, location of the saved files and the post-save command. Tracking and auto-renew are enabled by default by ipa-getcert.

pan_instcert will only log to stdout when executed directly. However, it will always log to /var/log/pan_instcert.log. When requesting certificates, it can be helpful to run a tail to see the post-save command logging in real-time. If the log file doesn’t yet exist the tail will fail.

sudo touch -a /var/log/pan_instcert.log
sudo tail -f /var/log/pan_instcert.log

Wrong SSL/TLS profile name

If the SSL/TLS Service Profile doesn’t exist it will be created, but the following error will be shown in /var/log/pan_instcert.log and the commit will fail:

commit: success: "Validation Error:
 ssl-tls-service-profile -> Test_profile  is missing 'protocol-settings'
 ssl-tls-service-profile is invalid"

Verify the API calls on the Palo Alto Firewall or Panorama

Check the following locations on the Palo Alto firewall for additional confirmation: Monitor >> Logs >> Configuration There should be 3-5 operations shown, depending on whether or not the SSL/TLS service profile(s) are being updated.

  1. A web upload to /config/shared/certificate.
  2. A web upload to /config/shared/certificate/entry[@name=’FQDN(_YYYY)’], under the FreeIPA root CA certificate.
  3. One or more web “set” commands to /config/shared/ssl-tls-service-profile/entry[@name=’YOUR_PROFILE(S)’]
  4. And a web “commit” operation.

To see all API actions, filter by the admin username used for API key: ( admin eq [api-admin] )

Under Device >> Certificate Management >> Certificates the new certificate should be shown with a valid status and under the manually imported IPA CA root certificate.

If any SSL/TLS Profiles were parsed, then under Device >> Certificate Management >> SSL/TLS Service Profile the respective profiles should show the new certificate has replaced the previous certificate.

Recent script changes

[2023-05-02] Looking into issuing a subordinate certificate from FreeIPA for a Palo Alto firewall, for user VPN certificates and ideally SSL interception. I found that I needed to specify a Certificate Profile in the ipa-getcert command, I thus went about adding option -T to pan_getcert.

Furthermore, I also added the following options:

  • -b Key bit length, 2048 is the default but it’s good to be able to request 3072 and 4096 length RSA certificates.`-b Key bit length, 2048 is the default but it’s good to be able to request 3072 and 4096 length RSA certificates.
  • -G Certificate type, currently only RSA is supported by FreeIPA. But it’s good to be ready for when EC and ECDSA certificates can be issued from FreeIPA. I don’t think this will be any time soon, but the code is there now.
  • -S Service type. The subordinate certificate isn’t for an HTTP service, in fact it’s best suited to being tied to a host rather than a service. So now there’s an option to specify a service, if omitted HTTP is assumed.

Palo Alto OSPF route filtering

 | 11 Apr 2023 14:41

To reduce the impact of lab testing bits and pieces, I decided to refresh my home network. The requirement I set myself is to reduce some of my family’s frustration when things go sideways, as it inevitably happens when trying out something new. Thus the point of the exercise is not just to refresh my memory or learn something new, but to create a clear separation between the home and the ‘lab’ networks.

The core of the domestic network will still be the same core switch and servers. But, any failures on the lab side should not affect the home network’s connection to the internet. Or as my kids would put it, the ‘WiFi’ must not go down. To my shame, and despite my many admonitions, our spawn persists in calling an internet connection “WiFi”.

In summary, my home network consists of a Ruckus ICX 7250 layer-3 capable switch. Not as polished as a Cisco but it’s an affordable second-hand switch with 48 POE ports and 8x 10GE SFP+ ports. The bulk of the compute and storage element is provided by two HPE DL380 servers, one gen8 (LFF with raid SAS storage) and the other gen9. I later added vSAN using Intel NVMe and 8TB SAS disks. It’s an organically grown mess, but it works and runs the latest version of vSphere 7 very well. Both servers are connected with 2x10GE (LACP LAG) for vSAN and VMs and 2x2GE for management.

Our FTTP terminates on a Palo Alto VM-50, and this is where vSAN and vMotion shine as this virtual firewall can move between the two ESXi hosts without missing a beat.

Initial setup and problem

At first, each VLAN was individually connected to the firewall, which worked great until the firewall went down (only for a software upgrade of course) and I could no longer connect to vCenter from my home network.

My solution was to introduce a Layer-3 link between the switch and the firewall. This made the switch the default gateway for the home network and I could then bring up a vlan interface on the switch to restore access to the management subnet if the firewall was unavailable. Routing between the switch and the firewall was static, which worked well enough, issues were only sporadic after all.

But then a DNS server on my network died and I figured I could do better, by removing lab/dev elements from the home network and giving myself direct access to that rather than traversing the firewall.

Current redesign

I had already used VRF-lite to configure the p2p routed link between the switch and the firewall for the home network. Doubling this for a work VRF was a simple progression while also ensuring that local traffic between work (access, server and management) subnets could flow freely without traversing the firewall. This should avoid management reachability issues for me the next time I upgrade the firewall. Additionally, I’ll be the only user connecting this way and there will be no direct wireless exposure of this VRF, limiting exposure of vSphere via potentially compromised clients on the home network.

I’m still undecided about which is harder to teach regarding cyber security, clients or family members…

Static or dynamic routing?

Moving subnets around becomes easier with dynamic routing protocols. This is what I needed to do and I figured it would be a good Palo Alto routing refresher. While the Ruckus switch supports RIP and OSPF, I went with OSPF as I figured it to be more relevant. Does anyone still use RIP these days? Please don’t answer that; there are too many things in tech that just won’t die…

OSPF

As I set out to add a second VRF to the switch and configure OSPF on it I found a couple of things that one should be aware of:

vSphere

  • When adding a new Distributed Port Group (DPG) on a vSwitch with a LAG uplink, ensure the advanced settings are changed to reflect this. This is obvious when initially configuring vSphere, but is easy to forget. So if you find that the switch doesn’t see an OSPF neighbor and the firewall does (stuck in init mode), check the settings of the DPG…

Ruckus

  • Simple straightforward configuration from the CLI, but there is no way to see or configure anything OSPF from the web interface.
  • With no need to filter advertised prefixes I didn’t check or test for prefix filtering. In fact I used area 0 (0.0.0.0) for all three routing instances.
    • Switch: Enabled OSPF on vrf LAN
    • Switch: Enabled OSPF on vrf WORK
    • Firewall: Enabled OSPF on the default virtual router
    • Set vlan ports to ospf-passive to include them in OSPF rather than redistribute connected.
      • This reduces network chatter, as no neighbor advertisements take place on passive ports.

Palo Alto

  • Only advertise a default route. As I’m using the backbone area (0.0.0.0) I can’t use a stub area for the switch, which would make it easier to advertise only a default route.
    • The solution is to use Redistribution Profiles. But, as there’s no comprehensive prefix-list with prefix length matching, one can’t match a default-route as follows:
      • 0.0.0.0/0 le 0
    • Instead, the 0.0.0.0/0 redist needs to be preceded (by priority) by a ‘no-redist’ object containing:
    128.0.0.0/1
    64.0.0.0/2
    32.0.0.0/3
    16.0.0.0/4
    8.0.0.0/5
    4.0.0.0/6
    2.0.0.0/7
    1.0.0.0/8
    Palo Alto – Virtual Router – Redistribution Profile – Redist Default

    The second requirement for filtering redistributed prefixes on Palo Alto is to add both Export Rules under the virtual router OSPF configuration. It took me some time to figure out that creating the Redistribution Profiles does nothing; applying them to the routing process does. It makes absolute sense once you notice.

    OSPF Ruckus configuration

    The following is the OSPF configuration of the Ruckus, including floating statics for the default routes (belts and braces):

    vrf LAN
     rd 65000:100
     ip router-id 192.168.100.1
     address-family ipv4
     ip route 0.0.0.0/0 192.168.199.0 15 distance 254 name fw01
     exit-address-family
    exit-vrf
    !
    vrf WORK
     rd 65000:101
     ip router-id 192.168.101.1
     address-family ipv4
     ip route 0.0.0.0/0 192.168.199.2 15 distance 254 name fw01
     exit-address-family
    exit-vrf
    !
    router ospf vrf WORK
    area 0.0.0.0
    !
    router ospf vrf LAN
    area 0.0.0.0
    !
    interface loopback 1
     vrf forwarding WORK
     ip address 192.168.199.253 255.255.255.255 ospf-passive
     ip ospf area 0.0.0.0
     ip ospf active
    !
    interface ve 100
     port-name LAN
     vrf forwarding LAN
     ip address 192.168.100.1 255.255.255.0
     ip ospf area 0.0.0.0
     ip ospf passive
    !
    interface ve 101
     port-name WORK-user-VLAN
     vrf forwarding WORK
     ip address 192.168.101.1 255.255.255.0 ospf-passive
     ip ospf area 0.0.0.0
     ip ospf passive
    !
    interface ve 198
     port-name WORK-Uplink-to-FW
     vrf forwarding WORK
     ip address 192.168.199.3 255.255.255.254
     ip ospf area 0.0.0.0
     ip ospf active
     ip ospf network point-to-point
    !
    interface ve 199
     port-name Uplink-to-FW
     vrf forwarding LAN
     ip address 192.168.199.1 255.255.255.254
     ip ospf area 0.0.0.0
     ip ospf active
     ip ospf network point-to-point
    !
    interface ve 400
     port-name Servers
     vrf forwarding WORK
     ip address 192.168.104.1 255.255.255.0 ospf-passive
     ip ospf area 0.0.0.0
     ip ospf passive
    !
    interface ve 700
     port-name Management
     vrf forwarding WORK
     ip address 192.168.107.1 255.255.255.0 ospf-passive
     ip ospf area 0.0.0.0
     ip ospf passive

    Checking OSPF

    Once the Palo Alto and both VRFs on the switch were configured and the vSphere Distributed Port Group issue was resolved both neighborships came up:

    Palo Alto – Virtual Router – Runtime Stats – OSPF Neighbors

    I left a couple of floating statics in place on the firewall, they’re shown below with metric 255.

    Palo Alto – Virtual Router – Runtime Stats – Route Table

    But as can be seen from the forwarding table, the OSPF learned prefixes are preferred:

    Palo Alto – Virtual Router – Runtime Stats – Forwarding Table

    And this is what things look like on the Ruckus:

    SSH@sw01#sh ip ospf vrf LAN neighbor
    Number of Neighbors is 1, in FULL state 1
    
    Port Address Pri State Neigh Address Neigh ID Ev Opt Cnt
    v199 192.168.199.1 1 FULL/OTHER 192.168.199.0 192.168.199.0 5 66 0
    
    SSH@sw01#sh ip ospf vrf WORK neighbor
    Number of Neighbors is 1, in FULL state 1
    
    Port Address Pri State Neigh Address Neigh ID Ev Opt Cnt
    v198 192.168.199.3 1 FULL/OTHER 192.168.199.2 192.168.199.0 5 66 0
    
    SSH@sw01#sh ip route vrf LAN
    Total number of IP routes: 9
    Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
    BGP Codes - i:iBGP e:eBGP
    OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
    Destination Gateway Port Cost Type Uptime
    1 0.0.0.0/0 192.168.199.0 ve 199 110/2 O2 5d4h
    2 192.168.100.0/24 DIRECT ve 100 0/0 D 13d4h
    3 192.168.101.0/24 192.168.199.0 ve 199 110/12 O 2m40s
    4 192.168.104.0/24 192.168.199.0 ve 199 110/12 O 2m40s
    5 192.168.107.0/24 192.168.199.0 ve 199 110/12 O 2m40s
    6 192.168.199.0/31 DIRECT ve 199 0/0 D 13d4h
    7 192.168.199.2/31 192.168.199.0 ve 199 110/11 O 5d4h
    8 192.168.199.253/32 192.168.199.0 ve 199 110/12 O 2m40s
    9 192.168.199.254/32 192.168.199.0 ve 199 110/11 O 5d4h
    
    SSH@sw01#sh ip route vrf WORK
    Total number of IP routes: 9
    Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
    BGP Codes - i:iBGP e:eBGP
    OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
    Destination Gateway Port Cost Type Uptime
    1 0.0.0.0/0 192.168.199.2 ve 198 110/2 O2 2m50s
    2 192.168.100.0/24 192.168.199.2 ve 198 110/12 O 2m50s
    3 192.168.101.0/24 DIRECT ve 101 0/0 D 4d21h
    4 192.168.104.0/24 DIRECT ve 400 0/0 D 5d4h
    5 192.168.107.0/24 DIRECT ve 700 0/0 D 5d3h
    6 192.168.199.0/31 192.168.199.2 ve 198 110/11 O 2m50s
    7 192.168.199.2/31 DIRECT ve 198 0/0 D 6d22h
    8 192.168.199.253/32 DIRECT loopback 1 0/0 D 5d21h
    9 192.168.199.254/32 192.168.199.2 ve 198 110/11 O 2m50s

    Summary

    Though I am now violating a stated requirement by advertising connected prefixes between the two VRFs, I’m not that bothered by this. The firewall filters traffic between the VRFs and matching my requirement would have meant creating two stub area networks, adding complexity. While possible, for my home network the current setup will do just fine.

    Equally, any prefixes which do not need internet connectivity are simply not added to the OSPF process and thus remain unknown outside the VRF. And prefixes which need more security like the DMZ, guest WiFi and IoT remain directly connected to the firewall.

    Conclusion

    All in all, deploying OSPF between Palo Alto and a Ruckus ICX 7250 proved to be an easy and successful exercise and no licenses were required on either device to support dynamic layer-3 routing. Both devices were at their latest available firmware.

    • Palo Alto: 11.0.0
    • Ruckus ICX 7250: 8.0.90j
    SSH@sw01&gt;sh ver
      Copyright (c) Ruckus Networks, Inc. All rights reserved.
        UNIT 1: compiled on Jan  5 2021 at 21:08:45 labeled as SPR08090j
          (33554432 bytes) from Primary SPR08090j.bin (UFI)
            SW: Version 08.0.90jT213
          Compressed Primary Boot Code size = 786944, Version:10.1.18T215 (spz10118)
           Compiled on Mon Jul 13 09:53:15 2020
    
      HW: Stackable ICX7250-48-HPOE
    ==========================================================================
    UNIT 1: SL 1: ICX7250-48P POE 48-port Management Module
          Serial  #:DUK3849N0JS
          Software Package: ICX7250_L3_SOFT_PACKAGE   (LID: fwmINJOpFlu)
          Current License: l3-prem-8X10G
          P-ASIC  0: type B344, rev 01  Chip BCM56344_A0
    ==========================================================================
    UNIT 1: SL 2: ICX7250-SFP-Plus 8-port 80G Module
    ==========================================================================
     1000 MHz ARM processor ARMv7 88 MHz bus
     8192 KB boot flash memory
     2048 MB code flash memory
     2048 MB DRAM
    STACKID 1  system uptime is 13 day(s) 7 hour(s) 45 minute(s) 46 second(s)